Developer forum

Forum » Dynamicweb 9.0 Upgrade issues
Subject
Replies
Started by
Last reply
Nuget package reinstall issues
Hiya, Lately we seem to get more issues installing DW updates using the "Manage NuGet Packages" menu option from Visual Studio. For example the update from 9.5.5 to 9.6.15 would not work at all, with continous dependency issues that seemed unsolvable ...
Hans Kloppenborg
11/10/2019 13:15:55
No replies yet
Validation issue on CartV2
Hi, can anybody offer any help as we seem to be going round in circles at the moment. We have recently upgrade a site from from DW8 to DW9 (9.7.1) and we are experience issues with the step validation on the shopping cart. Basically, the validation s ...
Kevin O'Driscoll
07/10/2019 12:56:39
Last post: 10/10/2019 11:38:35
CodeFirst items break on template (9.7.1)
Hi, Since 9.7 we can't use codefirst item in frontend. Templates crash when getting the item as codefirst objects like: var exampleItem = Services.Items.GetItemById<ExampleItem>("1"); It throws an exception because Dad is not happy... Is there  ...
Jesse Bakker
01/10/2019 16:48:58
Last post: 01/10/2019 17:32:10
Sitemap Products URL Domain is missing
In SiteMap Products URL Domain is missing we face this issue on 9.6.* any solution ...
Shiwanka Chathuranga
10/09/2019 07:53:45
Last post: 24/09/2019 16:09:18
Dynamicweb.Admin.dll missing in 9.7.x (net46)
Hello, It seems that Dynamicweb.Admin.dll is not include the in Nuget Package if you have targeted .Net 4.6 First screenshot is dw 9.6.11. Second is dw 9.7.1 Is does exist in the "\packages\Dynamicweb.Admin.9.7.1\lib\net472" but since my project is t ...
Søren Ravn Lund
12/09/2019 13:40:39
Last post: 23/09/2019 13:36:10
DbHandler.UpdateDataSet in DW9
Hi, We are upgrading a solution from DW8 to DW9, and can't seem to find a replacement for the Dynamicweb.Modules.Common.DbHandler.UpdateDataSet(DataSet set) function. We have a dataset that we want to commit. Alternatively, we can use a datatable. An ...
Tobias Belling
19/09/2019 10:50:15
Last post: 20/09/2019 14:01:14
Error in DW 9.7.1 (PIM module)
Hi, I installed a new DW 9.7.1 with Rapido 3.1.1 in a local server (with .net 4.7.2) and got an error when accessing to the product groups of the PIM module (see attached image): Server Error in '/' Application. Invalid column name 'Number'. Does som ...
Tomas Gomez
12/09/2019 14:44:40
Last post: 12/09/2019 15:42:04
Error calling DMConnection.GetConnections() in v.9.7.0
After we have updated the application to Dynamicweb version 9.7.0 we now get an weird error in an AX-project. The error comes when we call this method: DMConnection.GetConnections() from Dynamicweb.DataManagement. Translate.Translate or Translate.JsT ...
Niels Foldager
29/08/2019 17:42:23
Last post: 10/09/2019 13:26:52
Can't build repositories on 9.6.9 & 9.6.13
Hi, I'm unable to manually build my repositories, the problem occured on 9.6.9 and persisted after upgrading to 9.6.13. The console error, when I click on the build button is as follows: Error: $scope.status is null $scope.buildIndex@http://customer. ...
Harald Brouwers
09/09/2019 12:17:19
Last post: 10/09/2019 09:23:35
Upgrade to 9.7.0 causes epilepsy when adding product category fields.
I tried upgrading one of our solutions from 9.6.X to 9.7.0 and when I hit "Add new field" inside a Product Category the form window starts blinking uncontrollably and the input fields constantly refresh (go empty) Just wanted to let you know ;) Updat ...
Arnór Halldórsson
05/09/2019 17:14:18
Last post: 06/09/2019 14:54:06
Variant sort order issues
Hi there, I have an application running on 9.7. I entered a product with variants. In the CMS list display and in the GetLoop("VariantOptions") output the list is ordered by variantId in stead of the sortorder. This results in: VO1 VO11 VO2 VO3 VO4 e ...
Peter Leleulya
02/09/2019 08:44:51
Last post: 06/09/2019 02:10:33
Error accessing Field Display Groups in plain vanilla 9.7.0
Hi guys, I have just installed a fresh copy of 9.70 and Rapido 3.1.1 and when I try to access the details of a Field Display Group in the backend I get this error: Culture is not supported. Parameter name: name CH is an invalid culture identifier. Ad ...
Adrian Ursu
31/08/2019 09:33:02
Last post: 05/09/2019 15:16:31
9.6.13 to 9.7 - An item with the same key has already been added
Hi after upgrading a solution from 9.6.13 to 9.7 all paragraphs with the Product Catalogue using Index is returning this error: System.ArgumentException: An item with the same key has already been added. at System.ThrowHelper.ThrowArgumentException(E ...
Kim Søjborg Pedersen
04/09/2019 12:18:25
Last post: 04/09/2019 16:24:18
Error when entering Product Catalogue paragraph settings
Hi I have a solution which includes a custom Index Schema Extender. It's a Dynamicweb 9 solution upgraded to 9.6.9. Now when entering the paragraph settings of a product catalogue I get the error I have attached. What can be wrong? Any ideas? ...
Lars Larsen
22/08/2019 14:25:09
Last post: 27/08/2019 08:36:59
Products in Sitemap.xml
Hi there, I am trying to get products to show up in Sitemap.xml but I can't get it to work on a DW 9.4.9 site. Here's what I tried: 1. Enabled "Show products in sitemap" on Area settings 2. Assigned primary group to all products 3. Groups are set to  ...
Imar Spaanjaars
25/04/2018 09:19:50
Last post: 21/08/2019 11:05:45
Upgrading from 9.5.5 to 9.6.11 reflection error
Hi, I'm upgrading a solution from 9.5.5 to 9.6.12, but get an error after I build my solution with success. It works when I don't have dll's from the other projects in the bin folder. Anyone who have an idea of why the error comes? I have readded the ...
Marie Louise Veigert
23/07/2019 09:49:52
Last post: 26/07/2019 09:24:10
No table Show in Data List
Hi, Are there any setting to show table in Form for data list? I am using application 9.6.9. Regards, Tin Ma Ma ...
Tin Ma Ma
08/07/2019 14:24:38
Last post: 09/07/2019 08:59:57
Can't create a new language
Whenever we try to create a new website, we get the following error: https://www.screencast.com/t/x5P2wBsQdGM Dynamicweb Version: 9.6.6 Is anyone else experiencing the same issue? ...
Mikkel Belchuke
21/06/2019 10:55:43
Last post: 08/07/2019 14:13:51
GetLoginToken / LogOnWithToken issue
Hi guys, I have a question about the GetLoginToken and LogOnWithToken methods within the Dynamicweb.Frontend.LogonHandler. We have updated a project from DW 9.4.16 to DW 9.6.8 and since then a custom login functionality doesn't seem to work anymore.  ...
Peter Leleulya
12/06/2019 11:33:37
Last post: 21/06/2019 15:25:21
LoaderException when upgrading to 9.6.10 with Nuget
After upgrading to 9.6.10 via Nuget I receive the following error: https://i.imgur.com/JreFDHA.png If I download 9.6.10 as zip and view the Dynamicweb.Dashboard version it is 2.4.0 while the Nuget install retrieves 2.3.1. Using 2.4.0 fixes the issue. ...
Vincent Gercke
17/06/2019 08:55:57
Last post: 17/06/2019 16:35:37