Developer forum

Forum » Dynamicweb 9.0 Upgrade issues
Subject
Replies
Started by
Last reply
Versioning problem between 9.12 and 9.10.15
Hi there, We just upgraded a solution to 9.10.15 and upon startup, we got this error message saying that EcomLanguages does not contain a column called LanguageCulture: I searched the file ecom.xml.aspx for 9.10.15 for references to LanguageCulture b ...
Imar Spaanjaars
23/09/2021 14:17:26
Last post: 26/10/2021 13:10:51
Password Encryption - Extranet
We have just launched a new website for Lorenz Corporation on version 9.8.10. As part of the pre-launch steps, I was to encrypt all passwords. I am receiving an error when trying to ENCRYPT USER PASSWORDS for: PASSWORD SECURITY - EXTRANET It just dis ...
Nancy Morano
03/09/2020 17:15:19
Last post: 25/10/2021 16:19:53
Validation of viewstate MAC failed - 9.10.12+
Hello, Running into an issue on multiple sites where we receive a "Validation of viewstate MAC failed" error after trying to save changes to settings in the backend. I've primarily seen the error when making changes to security settings ...
KC Cook
19/10/2021 23:13:10
Last post: 25/10/2021 14:28:55
After upgrade to 9.10.15 Marketing not working
Hi I find out, that after update Marketing not working And the problem is 2021-10-21 10:15:30.203: TopFolderDescription. System.IndexOutOfRangeException: TopFolderDescription at System.Data.ProviderBase.FieldNameLookup.GetOrdinal(String fieldName) at ...
Andrejs Zavorotnijs
21/10/2021 10:25:30
Last post: 22/10/2021 03:38:57
Order lines NOT combining
Hi, A client recently pointed out several order lines that are identical except for OrderLineId (very wide screenshot attached) in the database for https://www.hewittrad.com/. Here is one example: select * from ecomorderlines where orderlineorderid = ...
Carolee Schuck
14/10/2021 22:28:51
Last post: 16/10/2021 01:14:24
OrderSearchFilter pulling seemingly random orders
Hello everyone, I am trying to pull all products ordered within the past 13months. Utilizing an OrderSearchFilter seems to yeild the same 4-5 products regardless of user, and those products have no coorelating orders. Seemingly a random set of produc ...
Kevin Byrd
07/10/2021 15:56:10
Last post: 13/10/2021 21:46:08
Monitoring error: The client disconnected.
Hi: Viewing the monitor i have seen the following error: This is the url: /Admin/Module/eCom_Catalog/dw7/edit/EcomProduct_Edit.aspx?ID=ImportedPROD1007&backUrl=/Admin/Module/eCom_Catalog/dw7/AllProducts.aspx%3Fpsearch%3D%26ppagenumber%3D1%26ppage ...
Jose Caudevilla
13/10/2021 13:39:24
Last post: 13/10/2021 14:34:46
Tell dev how you ended up here
Hi guys, After upgrading to 9.12.2 I got this error: Tell dev how you ended up here: Currency unknown. It is true that I am only using this solution for the PIM functionality but maybe this exception could have been caught and handled. Thank you, Adr ...
Adrian Ursu
13/10/2021 11:20:24
Last post: 13/10/2021 11:52:36
Urlname is empty after upgrading
Hi DW. I have a problem getting the URL for a page, i'm finding using navigationTag, and the urlname property. I do something like this: pageService = new PageService(); Page p = pageService.GetPageByNavigationTag(areaId, navigationTag); var url  ...
Daniel Hollmann
12/10/2021 13:53:53
Last post: 13/10/2021 09:17:45
Some completed orders are marked as deleted (dw 9.10.13)
Hi: I have a dynamicweb solution with version 9.10.13. Our costumer has indicate to us that he could not find an order. Searching the order id by Firehose SQL i find that the order has been set to deleted: Setting the Ordercomplete value to false the ...
Jose Caudevilla
29/09/2021 13:35:07
Last post: 30/09/2021 14:53:19
Platform Deletes Similar Orderlines
Hi, A client (Hewitt) reported incomplete invoices displaying on their production website. We can easily repro the problem on https://qa-walleye.dw-demo2.com (9.10.11) with the attached XML. The XML includes 11 lines, all of which are valid: 5 item l ...
Carolee Schuck
05/08/2021 00:42:34
Last post: 27/09/2021 19:57:31
9.10.14 upgrade - Brand colors are now transparent
Hi guys, I have just noticed that the brand colors are now rendered as "transparent" in the variables file after upgrading to 9.10.14. My solution is standard Rapido (latest) with standard Dynamicweb. The configuration worked well before th ...
Adrian Ursu
05/09/2021 13:25:38
Last post: 22/09/2021 14:26:11
Error deleting Groups 9.10.11
Hi guys, I have a solution running on DW 9.10.11 in DW cloud. I have configured a few Data Integration jobs and I have managed to import some sample data. However, when I try to manually delete a group from the interface, I get a pretty nasty error:  ...
Adrian Ursu
13/09/2021 18:45:51
Last post: 15/09/2021 08:56:06
Issue with assortment integration
Dear Dynamicweb, We have a solution running with this issue: Attempt by method 'Dynamicweb.DataIntegration.ProviderHelpers.AssortmentHandler.IsAssortmentToRebuild(Dynamicweb.DataIntegration.ProviderHelpers.AssortmentInfo)' to access method &# ...
Anders Ebdrup
07/09/2021 14:40:13
Last post: 09/09/2021 01:40:39
Updated to 9.12, but new google compression option not available
Hi Regarding the release of 9.12 and Nicolais webinar yesterday. I tried updating a solution I am working on to Dynamicweb 9.12, but the new compression option is not available. Is there something else I should do? /Hans ...
Hans Ravnsfjall
08/09/2021 10:55:30
Last post: 08/09/2021 16:53:09
9.10.12: ColorSwatch outputs name of color instead of value when using GetString()
We recently upgraded a project from 9.9.5 to 9.10.12 and now colors in emails are all messed up. The reason, I discovered, is that GetString now produces the name of the color rather than the HEX code. Using GetValue will product that value. The webs ...
Roald Haahr
14/07/2021 15:41:42
Last post: 24/08/2021 12:54:31
Problem with Item type field "Product"
Hi, We're trying to create a spot-product selector using the item type Product, to select a single product to display - we're running 9.10.13. But it seem the item only returns a productId-like string instead of a Product, something like => ...
Lasse Hove Nielsen
10/08/2021 15:01:37
Last post: 11/08/2021 16:54:26
Issues with Create User App Settings
Hello, I have run into an issue with Create User App settings, specifically the "Update existing users based on email match" and "use email for username". Neither setting seems to do what is listed in the documention. I have not t ...
Kevin Byrd
02/08/2021 20:24:22
Last post: 10/08/2021 18:21:05
Dynamicweb upgrade from 9.6.2 to 9.10.10 OwinStartup issues
Hi I'm having issues on a customer website afte upgrading from 9.6.2 to 9.10.10 The error i'm getting: I've tried to copy the admin folder from my local machine to staging (where this issue pops up), also i've tried to copy the bin fo ...
Thomas Berthelsen
26/07/2021 16:05:39
Last post: 06/08/2021 09:41:38
Export Job running fail after upgraded the Application version from 9.9.6 to 9.10.12
Hi all, I'm having an issue regarding Integration job failure. Hopefully, you all can help me. In one of our projects, we had upgraded the application version from (9.9.6) to (9.10.12) due to some features in (9.9.6) is not working. And, the Rapi ...
Nang Shwe Yea Oo
02/08/2021 05:49:16
Last post: 03/08/2021 13:17:45