Developer forum

Forum » Dynamicweb 9.0 Upgrade issues
Subject
Replies
Started by
Last reply
Dynamicweb upgrade from 9.6.2 to 9.10.10 OwinStartup issues
Hi I'm having issues on a customer website afte upgrading from 9.6.2 to 9.10.10 The error i'm getting: I've tried to copy the admin folder from my local machine to staging (where this issue pops up), also i've tried to copy the bin fo ...
Thomas Berthelsen
26/07/2021 16:05:39
No replies yet
9.10.12: ColorSwatch outputs name of color instead of value when using GetString()
We recently upgraded a project from 9.9.5 to 9.10.12 and now colors in emails are all messed up. The reason, I discovered, is that GetString now produces the name of the color rather than the HEX code. Using GetValue will product that value. The webs ...
Roald Haahr
14/07/2021 15:41:42
No replies yet
Custom dashboard widget does not compile
Hi Having upgraded from v9.9.1 to v9.10.12. Now my custom dashboard widget does not compile. Can't figure out how to fix it. Seems like you have reorganized the Dynamicweb.Dashboards namespace and now I can't find GridWidget. How do I fix thi ...
Lars Larsen
01/07/2021 15:54:47
Last post: 02/07/2021 09:30:06
SortIndex attribute on code first items does not seem to work
Hi, I try to control the sequence of my elements within a code first itemtype. I have a code first item that inherits properties from a base item, the problem is then that the itemtype editor puts the properties of the base class at the bottom of the ...
Ben Doorn
02/05/2017 10:39:36
Last post: 01/07/2021 14:15:47
shared translation not used
Hello, In our solution we are using only the shared translations. However for some reason, translation-keys that already exists in the shared translations keep getting created in the more specific design translation file, which I dont think is the ex ...
Frederik Gadegaard
12/04/2021 13:56:10
Last post: 23/06/2021 15:14:38
Combining products overwrites prod fields on Master Product
Hi, We have a customer running 9.10.7 We are trying to implement varaints for a customer but has run into an issue. They have multiple languages for their products and Name, Teaser Txt and Description have been translated for every language. When the ...
Keerthy Sethupathy
22/04/2021 11:28:03
Last post: 02/06/2021 14:23:27
admin issues
Greetings, We have recentrly upgraded DW to 9.9.8. After upgrading we have faced some issues and they are happening for random admin users These are some of the issues that we have noticed. The focal point is automaticaly set when admin user adds an  ...
Anton Marinó Stefánsson
27/05/2021 16:14:30
Last post: 27/05/2021 16:25:40
after Upgrading 9.10.1 to 9.10.8 product list getting very slow
we have done our site upgrade from 9.10.1 to 9.10.8 this contains almost 30k products, previously within 1 sec it generates the list and now almost 13seconds, any workaround?? ...
Shiwanka Chathuranga
17/05/2021 13:30:05
Last post: 18/05/2021 13:23:43
Field display groups gone after upgrade to 9.10.8
Hi, After upgrading to 9.10.8 all the fields in the different Field Display Groups were empty. I downgraded back to 9.10.1 and got them back. But we have quite a lot of them, with lots fields that are sorted so I really dont want to recreate all of t ...
Aki Ruuskanen
12/05/2021 09:48:05
Last post: 17/05/2021 08:19:31
Seems time to update installation documents
DW latest 9.10 uses STRING_AGG function which is introduced in sql server vNext comes with sql version 2017 onwards. better to update the documentation or version requirement with this details. Thanks ...
Shiwanka Chathuranga
03/05/2021 10:36:58
Last post: 06/05/2021 11:20:37
Dynamicweb API - Paragraphs
Hello When requesting paragraph data from the dwapi [/dwapi/content/paragraphs], if the page is a visual editor page then there seems to be no way to determine what rows the paragraphs belong to. For example, currently the json response is as follows ...
Natan Ólafsson
27/04/2021 17:10:55
Last post: 29/04/2021 15:25:16
Value cannot be null when adding product custom field
Hello, There appears to be a regressive bug in 9.10.7. We have it on 4 upgrades that we've done so I don't believe it's isolated to a particular site. When you try to add a new custom product field in the backend, you'll receive the error message bel ...
Scott Forsyth
20/04/2021 19:39:29
Last post: 29/04/2021 04:59:13
(9.10.5 issue) Issue displaying product fields on product detail page
After upgrading to 9.10.5 certain fields can't be displayed in the frontend on a product detail page, they show as an object instead of the actual value: It seems to be an issue related to the 9.10.5 upgrade, as I can't replicate it if I check out an ...
Frederik Rossen
23/04/2021 13:06:23
Last post: 26/04/2021 11:48:48
Custom Order Field of type DateTime is getting flushed by DW ....
Installation: Professional 2014 version 9.3.2 Staging/Test License I have several custom order fields of different types. Most of these fields are filled asynchrone via code, which works fine. I'm having troubles with my custom order fields of type D ...
Peter Leleulya
27/10/2017 13:53:27
Last post: 23/04/2021 11:17:42
User Permissions Issue/Potential Security Risk (9.10.4)
Hello, We have been doing some testing on User Permissions on a 9.10.4 site (https://sandbox.biolegend.com/) and have discovered that a login that has both frontend and backend access may be creating a potential security issue. Therefore, we wanted t ...
Nancy Morano
25/03/2021 17:06:26
Last post: 15/04/2021 16:06:32
Routing issues after 9.10 upgrade
Hello comrades, After upgrading one of our solutions to 9.10 we noticed that routing went haywire for root pages, all root page urls return the frontpage, these are the settings we're using: Website settings: Settings -> Web and HTTP -> Customi ...
Arnór Halldórsson
15/02/2021 15:36:57
Last post: 14/04/2021 11:58:01
File upload
I am having an issue on a solution that recently upgraded from 9.9.8 to 9.10.4, I cannot use the file uploader. [InvalidOperationException: The view 'SelectFile' or its master was not found or no view engine supports the searched locations. The follo ...
Unnsteinn Garðarsson
08/04/2021 11:39:24
Last post: 09/04/2021 13:30:21
Widgets not working
After upgrading from 9.9.8 to 9.10.4 we noticed that some widgets were not working anymore. This is not super urgent since the client is not using this all that much, but nevertheless I wanted to ask if anyone has encountered this before and if there ...
Unnsteinn Garðarsson
09/04/2021 13:10:50
Last post: 09/04/2021 13:30:17
After: Stock - After: RenderUnits
Hi, After upgrading a customer solution to 9.10.4, we are experiencing slow load time for productlists. When doing a debug=true, i can see that After: Stock and After RenderUnits are being called multiple times for each product and they take 200ms to ...
Keerthy Sethupathy
23/03/2021 13:11:36
Last post: 07/04/2021 15:50:18
Use domain for cookies not working after >9.9 upgrade
Hi, We noticed that the "Use domain for cookies" setting stopped working after we upgraded one of our solutions to 9.9.8, we also couldn't change the value of the check box in the admin so we updated to 9.10.5. That fixed the checkbox but the cookies ...
Arnór Halldórsson
07/04/2021 14:16:31
Last post: 07/04/2021 14:59:08