Developer forum

Forum » Dynamicweb 9.0 Upgrade issues
Subject
Replies
Started by
Last reply
Issues creating a new project on Dynamicweb version 9.13.0
Hello! After creating a new project using the newest DW version 9.13.0, I get in an endless loop between customerproject/admin and customerproject/Admin/Access/Setup/Default.aspx (302). Furthermore i get an error in Files/System/Log/Provider with the ...
Thomas Berthelsen
03/02/2022 14:30:07
Last post: 27/02/2022 21:15:16
Problem with images after upgrade to 9.12.9
We upgraded a solution from 9.10.11 to 9.12.9 and started to have a problems with images not displaying. Any new images that we add in the backoffice look broken and can not be used in the frontend (this can be seen in Image1). After clearing the cac ...
Cátia Torego
08/02/2022 17:45:05
Last post: 17/02/2022 23:15:17
No result for productService.GetProductByNumber
Hi guys, I have a 9.12.4 application which suddently didn't return a product anymore on the GetProductByNumber call. We found out that when we open a product in the CMS and save it without changing anything some fields in the database go from NUL ...
Peter Leleulya
17/02/2022 11:31:22
Last post: 17/02/2022 16:08:52
Error after upgradering to 9.13.1
Hi, After I upgraded a local solution to 9.13.1 and start up the app pool I get an error saying "Data is Null. This method or property cannot be called on Null values." Looking at the stacktrace you can see that its somethinh with the start ...
Aki Ruuskanen
14/02/2022 15:43:06
Last post: 15/02/2022 09:31:29
DW9.13.0 update from 9.10.8
Hi :) I have some question regarding update custom solution from 9.10.8 to 9.13.0. During the test of update I have notticed that live env can be down due to an error with LanguageCulture which column is not existed in DB on live env. So i have quest ...
Adrian Lesik
14/02/2022 12:04:31
Last post: 15/02/2022 09:23:41
After upgrade 9.13.0 Details loop are empty
Hi Checked in local and LIVE version In versions 9.10.x and 9.12.x we using Details loop for image rendering but in version 9.13.0 Details loop are empty => find images in another loops Is it some DW changes or bug? ...
Andrejs Zavorotnijs
03/02/2022 18:04:32
Last post: 15/02/2022 09:06:18
ribbon-section-button disabled (new product button)
Hi DW I recently upgraded a solution to 9.13.0. Afterwards i noticed that the new product button was disabled. The checkbox "disable creation of new product/variant" wihin the advanced configuration tab is unchecked (see below): Also The cu ...
Niklas Hjort
09/02/2022 14:45:12
Last post: 14/02/2022 11:56:00
Cannot add to cart in v9.12.4+
Hi I am having issues with adding to cart after updating to v9.12.4+ (also tried v9.12.7). I have already updated other projects and they do not encounter this problem, so it's exclusive to a single project. After updating nothing gets added to t ...
Natan Örn Ólafsson
13/01/2022 10:03:55
Last post: 10/02/2022 09:03:56
Culture error after upgrading to 9.12.7
Hi guys, I have a solution integrated with NAV (we are using Live integration 1.x). The solution was working pretty good on DW 9.9.8 but after upgrading to 9.12.7 we are noticing an error for some users: Culture ID 4096 (0x1000) is a neutral culture; ...
Adrian Ursu
19/01/2022 11:46:14
Last post: 27/01/2022 19:06:07
Anonymous cart products not being saved after user logs in DW 9.10.16
Hi We've noticed on newer versions that saving products in an anonymous cart, isn't kept when the user logs in, even though the "Keep anonymous cart when user logs in" and "Merge the anonymous cart content with the cart saved o ...
Fabio Monte
17/01/2022 13:42:00
Last post: 18/01/2022 02:55:21
Product picker does not return any value to the frontend after upgrade from 9.10.16 to 9.12.7
On a solution using a Rapido 3.4.3 the 'Content promotion product' element does not work as inspected anymore after upgrading the solution from 9.10.16 to 9.12.7. The selected products are not returned to the frontend. Kind regards, Roald ...
Roald Haahr
07/01/2022 09:50:38
Last post: 13/01/2022 12:05:24
Problem retrieving PDF documents using Live integration
Hi guys, I have a similar problem with the one Ricardo describes here: https://doc.dynamicweb.com/forum/integration/integration-integration-customer-center-requestexternalpdf-issue Basically, I have upgraded a solution from 9.8.x to 9.12.5 and the PD ...
Adrian Ursu
03/01/2022 17:03:56
Last post: 04/01/2022 08:52:16
CyberSource Error after Upgrade to 9/10.17
Hello, We are getting a strange error when trying to load the payment page/template for CyberSource after upgrading to 9.10.17. There are no logs available and the error code doesn't come up in a google search. See below for screen shot. I'm  ...
Kevin Byrd
15/12/2021 17:31:21
Last post: 15/12/2021 17:44:52
Can't delete page from admin
Hi, Every time I try to delete a page from admin i get this error. It looks like it has disapper in menu but if i restart app pool it comes back and i still can see it in the Page table in the database. How can i remove the page? What happens if i de ...
Andreas Pettersson
01/12/2021 10:58:16
Last post: 01/12/2021 12:33:39
NullReferenceException on user import
Hi guys, I have a 9.12.3. application where I tried to do a user import via CMS > Users > MyGroup (right click) > Import users. I used the CSV option, set all mappings, saved it. When I push the RUN button it returns a stack trace page, any  ...
Peter Leleulya
24/11/2021 08:56:47
Last post: 25/11/2021 13:12:57
dwapi carts order fields and order line fields missing value
Hello, I am wondering why the actual value of the order fields and order line fields are missing from the response of the api ? ...
Unnsteinn Garðarsson
24/11/2021 12:24:56
Last post: 25/11/2021 12:00:45
missing packages.config after 9.12.*
any reason not to ship packages.config after 9.12.* ? we are facing some issues when we configure VS with 9.12.* because of this ...
Shiwanka Chathuranga
01/11/2021 04:05:01
Last post: 25/11/2021 03:50:23
Dynamicweb.Modules.UserManagement.UserType issues on DW9 upgrade
Hi guys, I'm upgrading from 8.1 to 9.12.3. My project builds. All packages are 472 versions and no old dlls exist. I've managed to install Dynamicweb via Nuget (before the admin was a virtual directory) Now I've seemed to have end-up with ...
Peter Leleulya
05/11/2021 10:35:15
Last post: 05/11/2021 11:48:39
Dynamicweb.Caching issues when trying to update to DW9
He Guys, I've been asked to update a DW8.5.1.17 application to the latest version .... It was a customer/project which came to life which we hadn't worked on for some years. I got it working from our git repository on my system with a DW8.5.1 ...
Peter Leleulya
03/11/2021 13:40:07
Last post: 03/11/2021 13:48:20
Versioning problem between 9.12 and 9.10.15
Hi there, We just upgraded a solution to 9.10.15 and upon startup, we got this error message saying that EcomLanguages does not contain a column called LanguageCulture: I searched the file ecom.xml.aspx for 9.10.15 for references to LanguageCulture b ...
Imar Spaanjaars
23/09/2021 14:17:26
Last post: 26/10/2021 13:10:51