Developer forum

Forum » Dynamicweb 10
Subject
Replies
Started by
Last reply
Error exporting all products to Excel
Hi, I have setup an integration acitvity, that should export all products to excel. I get the following error (I tried deleting a product to see if the data was causing this, but it crashes on the next products) I think all setting are "standard ...
Justin Sjouw
22/01/2024 12:29:26
Last post: 23/01/2024 08:45:45
No paging or search in "Assign data set" panel
Hi, I'm trying to assign a DataSet to a data model on a product. On the website mountainbikemuseum.nl I have 185 Data Sets defined, but it seems the panel shows only 96, maybe the panel should show paging and there is an issue there? Also it woul ...
Justin Sjouw
22/12/2023 20:16:17
Last post: 23/01/2024 08:37:17
dwapi/frontend/navigations/3?ExpandMode=All&IncludeFoldersAndHidden=True incorrectly returns hidden pages as showInMenu: true
Running 10.0.26 on swift 1.25 and when trying to consume dwapi via dwapi/frontend/navigations/3?ExpandMode=All&IncludeFoldersAndHidden=True im getting the wrong value on showInMenu. In images you can see that Home-page is set to hide in menu, yet ...
Joakim Sjöbäck
08/01/2024 14:25:24
Last post: 22/01/2024 20:55:09
dwapi does not return theme but visible in template
dw 10.0.26 & swift 1.25 consuming api via dwapi/content/rows/150?device=0 returns empty theme field, but its visible and accesible in the .cshtml template. Also tested on dw 9.15.16 with same result ...
Joakim Sjöbäck
10/01/2024 11:51:24
Last post: 22/01/2024 09:35:16
Sitemap.xml
I have a couple of dw10 solutions, none of which seem to generate a /sitemap.xml. Any special settings I have to enable to make it appear or is it still in the pipeline? I was looking for the checkbox to enable the Sitemap based on the URL provider,  ...
Justin Sjouw
16/01/2024 11:02:19
Last post: 19/01/2024 22:13:01
dwapi/content/pages?PageId=149 returns "The query returned no pages"
So i'm running swift 1.25 on dw 10.0.26 and as title says dwapi/content/pages?PageId=149 returns "The query returned no pages", but the same request properly returns pages on a swift 1.25 on dw 9.15.11. Is the issue related to dw10 or a ...
Joakim
17/01/2024 16:38:17
Last post: 18/01/2024 11:05:15
Possible solution for headless dynamic product details page?
Hi, I'm running a Vue app consuming the DWAPI. I'm attempting to implement the same functionality where the product details page is dynamic, as is in Swift. So the issue is how to get a link to the product details page, when in the product li ...
Joakim
17/01/2024 10:00:12
Last post: 18/01/2024 08:43:36
Item option selectors not visible in Dark Mode
Hi, The selectors for items like the Arrow placement on sliders is not visisble in Dark Mode: https://screenrec.com/share/mgrK3DG8E2 Br, Justin ...
Justin Sjouw
16/01/2024 09:46:25
Last post: 16/01/2024 17:30:29
Scheduled Task failed logs as information
When a scheduled task fails, it logs as information. It would make sense if it is logged as an error: ...
Justin Sjouw
29/12/2023 21:01:11
Last post: 15/01/2024 15:23:43
Saving a task renames the parent scheduled task
I see that I can now add multiple tasks to a schedule task, that's awesome! I did find an issue with the naming, when I create a scheduled task, add a task to it and then save the task, the parent scheduled task is renamed as well as the task its ...
Justin Sjouw
29/12/2023 20:54:24
Last post: 15/01/2024 15:23:26
Error when saving Live Integration
I'm getting this, any idea? (The settings do get saved) 2023-12-28 21:16:53.5281: Management API request failed. Trace ID: 00-80371075298f86c4252e464b56da91e5-4f80a7cd7b475017-00. System.MissingMethodException: Method not found: 'Void Dynamic ...
Justin Sjouw
28/12/2023 21:22:17
Last post: 15/01/2024 10:57:16
Refresh instead of repeat
Hi, I think this probably should be repeat instead of refresh: ...
Justin Sjouw
29/12/2023 20:39:53
Last post: 11/01/2024 13:09:12
Exception in local app installed through appstore
I'm getting an exception when interacting with an installed local app addin: An unhandled exception has occurred while executing the request. System.ArgumentException: Value cannot be null or an empty string. (Parameter 'value') at NuGet. ...
Jóhannes Þorkell Tómasson
10/01/2024 08:59:01
Last post: 11/01/2024 12:14:58
NotificationSubscribers not triggering in DW10
Sup guys, We're having troubles triggering notification subscribers in dw 10. I've tried both of these cases: using Dynamicweb.Extensibility.Notifications; public class TestNotificationSubscriber : NotificationSubscriber { [Subscribe(Dynamicw ...
Arnór Halldórsson
09/01/2024 14:23:02
Last post: 10/01/2024 10:05:37
dwapi/content/pages/url?url=%2Fcontact returns 404
Im trying to get the page data via url(testing on https://dw10swift.public9.dynamicweb.dk/) /contact is a published page on the site https://dw10swift.public9.dynamicweb.dk/dwapi/content/pages/url?url=%2Fcontact but it returns 404. Afaik the only req ...
Joakim Sjöbäck
08/01/2024 16:19:44
Last post: 09/01/2024 15:47:23
Request for DW 10 sites
Hi, A customer wrote: We're starting to look at the feasibility of moving our site to DynamicWeb 10. I'd like to get several examples of sites that use the latest version, including e-commerce, so that we have some clarity around the capabili ...
Sean Meade
08/01/2024 20:54:12
Last post: 09/01/2024 14:54:22
Error when installing addin through appstore on wsl2 ubuntu
When I try to install addins through the appstore through DW10 admin UI on ubuntu it doesn't work correctly. The feedback from the UI indicates success but the addin isn't usable. The problem seems to be in the generated path hierarchy of the ...
Jóhannes Þorkell Tómasson
08/01/2024 17:00:18
Last post: 09/01/2024 09:59:04
Use customized URLs returns Default.aspx?ID={page} when consuming DWAPI
Im running swift 1.25 on dw 10.0.26 and ive enabled Use customized URLs but dwapi/frontend/navigations/{id} returns link with format Default.aspx?ID={page}. ...
Joakim Sjöbäck
03/01/2024 12:06:08
Last post: 04/01/2024 13:00:26
Error when attemption to view SwiftProducts repository
Hi, I'm running DW 10.0.26 on swift 1.25 and im trying to access the SwiftProducts repository but getting an Error: ...
Joakim Sjöbäck
04/01/2024 10:18:12
Last post: 04/01/2024 12:53:04
Error when saving Scheduled task with Digital Asset Checkin
When I save a scheduled task with the Digital Asset Checkin task, the task is saved, but the log shows an error. The task does not work (it is converted from dw9 and does work there) but I'm not sure if that is related. The error is: 2024-01-03 1 ...
Justin Sjouw
03/01/2024 15:56:36
No replies yet