Developer forum

Forum » Dynamicweb 10
Subject
Replies
Started by
Last reply
Different DW version on IIS/localhost
Hi, Im running a 10.1.4+ application hosted on IIS, but when visiting /admin via the IIS-site it shows an older version(10.0.36+), but when hosted on localhost(dotnet run), it properly shows the correct version(10.1.4+). Is this a setting in IIS? Or  ...
Joakim
22/02/2024 12:25:19
Last post: 23/02/2024 10:24:06
dwapi - query ecommerce/products with active facets
Hi, I'm running DW 10.1 and a headless vue app for the front. Im trying to achieve a filtering-function when applying active facets. When looking at the dwapi docs im unsure how to properly send these params. If anyone would be so kind as to writ ...
Joakim
16/02/2024 11:33:03
Last post: 19/02/2024 17:19:44
Update license in DW10
Hi, I have a DW10 site running a trial license. I know I can delete the license file to trigger the UI and setup the license accordingly, but is there a way I could do that from the backend? I'm in Settings > System > License but I can' ...
Nuno Aguiar
15/02/2024 17:43:31
Last post: 19/02/2024 12:35:07
Local Addin not pickedup and "scramled" after AppPool recycle
Hi, I have a template that uses CsvExport https://www.nuget.org/packages/CsvExport I installed the CsvExport dll via the dw CLI, and also did a manual upload and install, which is showing some weird behaviour. Either way the template give an error th ...
Justin Sjouw
11/01/2024 11:24:06
Last post: 19/02/2024 12:10:12
Redirects
I can see that redirects I had defined in 9 via https://doc.dynamicweb.com/documentation-9/platform/platform-tools/redirects still work. But I cannot manage them in Settings - Web & HTTP it seems? For now I can edit the rows directly in the datab ...
Justin Sjouw
19/02/2024 11:52:55
Last post: 19/02/2024 11:59:20
dwapi/ecommerce/products?RepositoryName=SwiftProducts&QueryName=Products returns 204
running dw 10.0.26 and swift 1.25, when attemption to consume API via post dwapi/ecommerce/products?RepositoryName=SwiftProducts&QueryName=Products im getting 204 - No content Index is built, and fetching products via group works fine. What am I  ...
Joakim Sjöbäck
10/01/2024 11:22:33
Last post: 13/02/2024 02:43:09
Bug when saving a paragraph in 10.1.2 + etc
Hi DW When saving a paragraph, whenever i have a file as an itemtype field, whatever the path might be, Files/Images gets appended to the path string. I fixed this by not having Files/Images as a base directory. Also when using the "Sort paragra ...
August Schnell
08/02/2024 18:29:55
Last post: 09/02/2024 10:59:36
Grid Edit removed on 10.1.2?
Hi, In 10.1.2 it seems the grid edit has been removed. When I downgrade to 10.1.1 I can open grid edit on products lists... 10.1.2 10.1.1 ...
Justin Sjouw
08/02/2024 08:44:59
Last post: 08/02/2024 08:56:07
Possible dropdown bug for version 10.1.1
Hi DW There seems to be an issue regarding all dropdowns in DW 10.1.1 Whenever i choose an option in a dropdown and click save, no matter what it gets saved as "undefined" Manually editing in this case "AreaLayout" in the Area tab ...
August Schnell
07/02/2024 15:17:41
Last post: 07/02/2024 16:09:21
Maximum file size in assets?
Hi DW, I was wondering if there is a maximum file size for what you can upload into assets? Currently im trying to upload a video on 46mb which ends up giving me an error, but a video on 27mb is allowed? And maybe if there is a place to control this? ...
Martin Ottesen
06/02/2024 13:27:26
Last post: 07/02/2024 10:26:01
Import data with Paging add-in?
In my dw9 setup I have a task using the Import data with Paging add-in. I can't seem to find it in dw10, is it not there (yet) or is it replaced by something else? ...
Justin Sjouw
29/12/2023 15:34:24
Last post: 06/02/2024 13:55:48
Import Data With custom request seems to only execute Integration Activity
Hi, I have a task that has been running for a long time correctly on dw9, in 10 it fails, and gives me the impression that only the Integration acitivity is executed. The configured endpoint to the CodeUnit works when I run a test on it: ...
Justin Sjouw
29/12/2023 23:30:07
Last post: 06/02/2024 13:52:44
Swift update needed for dw10.1
I followed this guide, which does not mention anything about Swift. But found out at least 1 issue with the OffCanvasNavigation that is solved in 1.25.1. Maybe it is a good idea to mention that for 10.1 a certain Swift version is needed as well? http ...
Justin Sjouw
02/02/2024 11:16:33
Last post: 02/02/2024 11:56:16
Update to 10.1 with IIS hosting
Hi, I used zipped releases up until now to achieve a multi-tenant iis hosting setup. Since I'm a bit inpatient updating to 10.1 which is not on the zipped list yet:-) and want to automate deployment of the dw10 application folder, I have setup a  ...
Justin Sjouw
31/01/2024 12:58:17
Last post: 31/01/2024 13:19:36
Error when creating new user in DW10 admin
Hi, I get an error when trying to create a new user from this view in the admin in DW10: Error: An unhandled error occurred 10:09 An unhandled error occurred: Cannot insert the value NULL into column 'AccessUserRead', table '[table_name]. ...
Arnór Halldórsson
31/01/2024 11:25:34
Last post: 31/01/2024 13:11:11
404 error page
At the time of writing, the solution is on version 10.0.25 In standard dw9 + Swift we have this 404 result by default In dw10 there is a website setting "404 page" I assume the 404 page field on the website settings is a replacement for thi ...
Igor Ivanov
09/01/2024 11:23:33
Last post: 31/01/2024 08:40:36
Anywhere to see dw 10 release notes?
Maybe I havent searched enough but is there a place to see the changes/fixes in the minor releases? ...
Joakim Sjöbäck
25/01/2024 08:05:52
Last post: 30/01/2024 22:51:06
Field item_tab renders as input field and not in tab
I'm running dw 10.0.27 & swift 1.25, and im adding custom item_tabs to Master item_type, and it renders this: Also tested on Swift default on dw 9.15.11 and it works properly there. Is this a bug or am I missing a settings? Thanks ...
Joakim Sjöbäck
19/01/2024 11:02:29
Last post: 30/01/2024 21:55:07
Themes not showing in editor
I'm updating a couple of websites from 9 to 10, alle 3 show the same behaviour. The themes render fine on the Themes page (also did a hard refresh, and cleared history) but in the editor the previews are blank: ...
Justin Sjouw
29/11/2023 16:21:23
Last post: 30/01/2024 21:01:17
App Addins with custom Templates
I was wondering if you had some sort of best practices regarding custom templates when extending DynamicWeb functionality through Apps. I'm creating a CheckoutHandler that requires a custom template. The CheckoutHandler is in a separate project b ...
Jóhannes Þorkell Tómasson
22/01/2024 13:58:21
Last post: 24/01/2024 13:09:41