Developer forum

Forum » Integration » How to avoid encoding of æ ø å in a product export?

How to avoid encoding of æ ø å in a product export?

Pernille Mortensen
Reply

I am making a product export (an xml file of all products) using the data integration. One of the fields in the product export is the product description, which is the standard wysiwyg ckeditor in the backend.
The product descriptions are in Danish and contain æ ø å. These are encoded into aelig; oslash; and aring; when the product is saved, and this encoding is also in the finished product export xml-file. 

We are making this export for a third party system, which cannot handle this encoding and would prefer æ ø å instead. Is there any way to avoid the encoding in the export? Either by avoiding the encoding in the first place when the product is saved, or even better by decoding/removing it when making the export? 


Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Hi Pernille

You have to change the editor configuration to not encode æ, ø and å. If you use the CKEditor you have to create a custom config file and set it up to not encode. Requires a bit of technical skills. You need to set the htmlencodeoutput setting on the editor to false. See https://ckeditor.com/docs/ckeditor4/latest/api/CKEDITOR_config.html#cfg-htmlEncodeOutput

You find the editing configuration sin settings - see https://doc.dynamicweb.com/documentation-9/platform/advanced-settings/editing#3526

We do not have a lot of doc on this - but you need to use a .js config file. You should have some already and they can be used as a starting point

 
Pernille Mortensen
Reply

Thank you for your answer.

That makes perfect sense. I will look into it.

 

 

You must be logged in to post in the forum