Developer forum

Forum » CMS - Standard features » Mailings with personalisation keeps hanging

Mailings with personalisation keeps hanging

Willem Ruiter
Reply

Hi support, 

For one of our customers we make use of the e-mail marketing within Dynamicweb 9.7.3. The regular e-mails are sending correctly, but the ones with personalisation in them not. We have increased the max. mailing size on the mailserver, but also with no effect. Let's say there is a mailing with 5.000 recipients, the mailing stucks around 1.000. After clicking resend the mailing goes further, but gives also an error on the unsubscribe link for the following batches.

Do you need more info to investigate this?

Kind regards,

Willem Ruiter

Replies

 
Morten Bengtson
Morten Bengtson
Reply

Hi Willem,

It would be helpful if you could provide more details about the errors you mention (error message, stack trace, log entries).

Go to Settings > System > Event viewer and see if any errors have occurred.

Note: This is just a forum. If this is urgent and you need actual support then I will suggest that you contact our service desk and provide details about the problem and how to access your installation of Dynamicweb for further investigation.

Best regards,
Morten

 
Willem Ruiter
Reply

Hi Morten,

Thanks for your quick reply. Please see the attachments.

Kind regards,

Willem Ruiter

DW-mail-error-1.JPG DW-mail-error-2.JPG DW-mail-error.JPG
 
Morten Bengtson
Morten Bengtson
Reply

Hi Willem,

I can see that a ThreadAbortException was thrown.

Can you go to Settings > Marketing > Email Marketing and see what the value for sending timeout is?

The timeout is set to 720 minutes by default.

Do you see any other errors in the event viewer right before/after the errors you have attached?

/Morten

 
Willem Ruiter
Reply

Hi Morten,

I don't see any sending timeout settings at Settings > Marketing > Email Marketing. See attachment. 

Couldn't filter the specific mailing out of the event viewer due to the missing date filter. I have sent this case to the customer support with the login credentials. Maybe you could take a look by yourself to find the needed information.

Kind regards,

Willem

Mail-settings.JPG
 
Morten Bengtson
Morten Bengtson
Reply

Oh, that setting is not available yet - my bad. It will be there in version 9.7.5

If you are using nuget packages then you can update Dynamicweb.Mailing to version 3.0.7 which will increase the timout to 12 hours.

Alternatively you can try to change the value of executionTimeout in web.config. However, this should only be done as a temporary workaround:
https://stackoverflow.com/questions/20901388/difference-between-executiontimeout-and-server-scripttimeout

/Morten

 
Adrian Ursu
Adrian Ursu
Reply

Hi Morten,

They are already running with Dynamicweb.Mailing 3.07

My guess is the automation hangs whenever there are invalid email addresses. I have seen it in previous versions. Not sure if it this is the exact issue.

Do you know if there is any check for invalid email address in the automated sending?

Adrian

 
Morten Bengtson
Morten Bengtson
Reply
This post has been marked as an answer

Sorry, it is Dynamicweb.Mailing version 3.0.8 which has the increased timout.

The "Dynamicweb users" recipient provider checks if each email address is valid.

/Morten

Votes for this answer: 1
 
Adrian Ursu
Adrian Ursu
Reply
This post has been marked as an answer

Hi Morten,

Thank you.

We will upgrade and see what happens.

Adrian

Votes for this answer: 1
 
Willem Ruiter
Reply

The Dynamicweb.Mailing version 3.0.8 has fixed the issue. 

 

You must be logged in to post in the forum