Developer forum

Forum » Feature requests » Hiding Scheduled Task warning if app pool doesn't have enough access

Hiding Scheduled Task warning if app pool doesn't have enough access

Scott Forsyth
Scott Forsyth
Reply

All of our websites that are properly locked down so that the IIS app pool has limited permissions. This means that the Dynamicweb check to create or confirm the Windows scheduled task fails. This results in in an error message that says: "Windows scheduled task is not found". However, it's not really a problem and the error is benign in most cases. 

Because we lock down our web servers, it's not possible for the website to have enough permissions to check the Windows scheduled task. We're fine with that, and we run impersonation when doing the initial setup.

However, the warning message is distracting for people. Personally, I've become blinded to it, but our customers often ask if that's a problem. I tell them to ignore it. But, it would be nice to be able to have that type of message not even show. 

Would it be possible to have a global setting to let us turn off this message? (and there is a second similar message that occurs at other times, possibly when a new task is created).

We don’t want to ever show a message about the Windows scheduled task. We do want to show all other messages though.
 

Thanks,

Scott


Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Yes, of course! Will have it created as soon as possible.!

BR Nicolai

 
Oleg Rodionov Dynamicweb Employee
Oleg Rodionov
Reply

Hi all,

New TFS #45372 has been submitted to implement the feature, will be fixed on a further DW version. Thanks.

BR, Oleg QA

 
Scott Forsyth Dynamicweb Employee
Scott Forsyth
Reply

Great, thanks Oleg and Nicolai. 

 
Ben Doorn
Reply

+1

 
Aki Ruuskanen
Aki Ruuskanen
Reply

Hi,

Has this been implemented yet?

/Aki

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Apparantly not - it was added to a 'later' release and never picked up.

I've added it to 9.7 release track.

BR Nicolai

 
Scott Forsyth Dynamicweb Employee
Scott Forsyth
Reply

Thanks for this. I see the setting in Settings > Solution Settings > "Disable 'Windows scheduled task not found' warning" and it works well. 

 

You must be logged in to post in the forum