Developer forum

Forum » Ecommerce - Standard features » ShopCompletionLanguageIds

ShopCompletionLanguageIds

Helene Kjærbøl
Helene Kjærbøl
Reply

 

Hi forum,

Has anyone seen this error message before?

The error message occurs when I try to enter the Ecommerce section. The Pim section is down as well - but without any error message.

Fingers crossed that any of you know something cool.

BR Helene

 

Replies

 
Steffen Kruse Hansen
Steffen Kruse Hansen
Reply

Hi Helene,

It looks like you are missing a column in your database, which is probably caused by update-scripts not running on your solution. You can run the updates yourself if you go to 'Settings/System/System information' and at the bottom of that page, you need to change the number in 'ecom.xml.aspx:' to 2100 and then press the 'Rerun updates' button.

After that finishes everything should work again.

 

Best regards,

Steffen

 
Helene Kjærbøl
Helene Kjærbøl
Reply

Hi Steffen,

Thank you very much for answering on this.

I am afraid this didn't solve the problem right out of the box. Is there anything I should do after this? Running index, restarting IIS or how?

BR Helene

 
Steffen Kruse Hansen
Steffen Kruse Hansen
Reply

Hi Helene,

That's strange.

Can you see if the 'EcomShops' table has gotten the 'ShopCompletionLanguageIds' column? If it has gotten it, you probably just need to restart the IIS.

If that doesn't work, you need to look at the Update-logs (which can be downloaded at the same place, where you reran the updates), because this could be caused by the database-user not having the correct permissions to make changes to the database schema.

 

Best regards,

Steffen

 
Helene Kjærbøl
Helene Kjærbøl
Reply

Hi Steffen,

Ok thanks again :-). Yes it has this column - I wil restart the ISS - and let you know...

BR Helene

 
Helene Kjærbøl
Helene Kjærbøl
Reply

Hi Steffen,

It is up and running agian laughyes

Thank you very much - and for being so fast on a solution.

BR Helene

 

You must be logged in to post in the forum