Developer forum

Forum » Ecommerce - Standard features » Autologin not working with full impersonation

Autologin not working with full impersonation

Anders Ebdrup
Anders Ebdrup
Reply

Hi Dynamicweb,

 

We have some issues with the login procedure when using the full impersonation feature;

  1. The AutoLogin feature is not working after having impersonated a user
  2. The impersonated user is not remembered after session timeout

These issues are registered on Dynamicweb 9.5.8. I hope that this can be fixed?

 

Best regards, Anders


Replies

 
Morten Snedker Dynamicweb Employee
Morten Snedker
Reply
This post has been marked as an answer

Hi Anders,

I've been testing on a 9.6.12, and the auto-login feature seems to work as intended.

If I run the browser in cookieless mode, however, the autologin does not work. If cookies are allowed, all is good: Closing browser entirely, recycle AppPool, open new browser and reentering the website, I am recognized (and logged in) as the impersonated user.

Let me know if there is any scenario I may have missed.

Best regards
Morten Snedker | Helpdesk

Votes for this answer: 1
 
Anders Ebdrup
Anders Ebdrup
Reply

Sounds great! Thank you :-)

 
Mario Santos Dynamicweb Employee
Mario Santos
Reply

Hi Morten,

We are running on 9.7.2 and the AutoLogin feature is not working.

The cookie DW_Extranet is changed to be valid for the current session only which causes the AutoLogin to not work.
Here's a repro scenario: https://www.screencast.com/t/BeAYH9QQ

 

Thanks,
BR, Mario

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Hi Mario

What is your login cookie lifetime set to? See dump?

Capture.JPG
 
Mario Santos Dynamicweb Employee
Mario Santos
Reply

Hi Nicolai,

It's set to 3 days.

BR, Mario

 
Oleg Rodionov Dynamicweb Employee
Oleg Rodionov
Reply

Hi all,

The issue is reproduced on DW976 and up, it's now bugged by TFS 76230 has been created, will be fixed on upcoming DW release. Thanks.

BR, Oleg QA

 

You must be logged in to post in the forum