Developer forum

Forum » Development » Can't access web installer : redirected you too many times

Can't access web installer : redirected you too many times

Joel Setterberg

I have a problem with installing Dynamicweb.. I have installed version 9.12 using the Zip file. I followed the procedures, I copied the contents in dynamicweb.web.config into Web.config.

When accessing the page I think it redirects infinitely between two urls. It says:

This page isn’t working

(site url) redirected you too many times.

I checked the redirects, it happens between these urls:


Regarding .Net versions I ran a program which says:

"Currently installed "classic" .NET versions in the system:

I think this happened after installing the scriptwith the "windows features" at the "Preparing a hosting environment" page.. (

I think I already installed that script before, but coould there be trouble if installing it a second time(?)

If someone could guess what the problem may be related to, would be nice.  I also can mention that I have got other errors for when installing through Nuget I got an error saying: "conflicts between different versions of the same dependent assembly." . Maybe it is related to this problem, or it's something separate..


Nicolai Pedersen

Hi Joel

Yes, that is an error we made in the installer in the latest release due to a security hotfix.

It has been solved in 9.12.10 which you can find from today here:

Jeppe Persson Dynamicweb Employee
Jeppe Persson

Hi Nicolai. 

I have ran into a similar issue. I am using 9.13.0. Is this error also related to that version. And if it is, will it be fixed in 9.13.1?

Nicolai Pedersen


Arker Soe
Arker Soe

Hi Nicolai,

I am able to run and setup the current latest, 9.13.2.

However, when I run an old versions, it keeps happening (site url) redirected you too many times. issue.

You know, I need to run old version for my development as our current Production(Live) is still using 9.6.x.

My PC is running Windows 10 , IIS 10, and .Net Frameworks(up to 4.8).

Looking forward your advise.


Nicolai Pedersen

Are you running the latest 9.6? Maybe that hotfix contains a bug.

You can do your local installation following this guide:

Then the installer will not be required - and you have an existing solution with database to the above guide.

BR Nicolai


You must be logged in to post in the forum