Developer forum

Forum » CMS - Standard features » Username gets overwritten by email in Extranet

Username gets overwritten by email in Extranet

John Broers
Reply

We made a 'my profile' page where users can edit their personal information like email, password, firstname and lastname through the Extranet app. But when you save the form the username of the profile automaticly gets overwritten with the email that has been filled in. Even though the username field is not part of the submitted form. I tried adding the username field and checked the submitted data in the request. The correct username is there, but the username is still overwritten with the email address.

I'm using the following tags:

<input name="UserManagement_Form_Email" type="email" id="UserManagement_Form_Email">
<input name="UserManagement_Form_UserName" type="text" id="UserManagement_Form_UserName">

Am i missing a setting somewhere? Or there something else wrong? 

 


Replies

 
Morten Bengtson Dynamicweb Employee
Morten Bengtson
Reply

The Extranet app has a "Use email for user name" (checkbox). Is that setting enabled?

 
John Broers
Reply

Hi Morten,

We did enable that option on our register page where we use the Extranet app with the 'Create profile' option. But on this page we use the 'Edit profile' option of the Extranet app, and i don't see that checkbox there.

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Try switch to the Create profile mode on the edit profile page. Then check if the checkbox is set... Or we need a link to the page and see how things are configured.

 

You must be logged in to post in the forum