Developer forum

Forum » CMS - Standard features » Pages on language layers - Paragraphs not published

Pages on language layers - Paragraphs not published

Ivan Marijanović
Ivan Marijanović
Reply

Hi guys.

One quick question. When I create new page it is created in all language layers but all paragraphs are not published. I think i saw somwhere option to turn this to published by default but now I cant find it. 

We are running 9.6.9 version with 2.11 Rapido.

Thank you in advance!

Ivan

Replies

 
Morten Bengtson
Morten Bengtson
Reply

Hi Ivan,

Can you check the configuration of language management (Settings > Control Panel > Language Management)?

https://doc.dynamicweb.com/documentation-9/platform/advanced-settings/control-panel#6719

Please attach a screendump of your current settings if you are unable to get the expected results.

Best regards,
Morten

 
Ivan Marijanović
Ivan Marijanović
Reply

Hi Morten 

I found this in documentation but I dont have this page in my Control Panel. I am attaching the screenshot.

Thank you

Ivan

Control_Panel.png
 
Morten Bengtson
Morten Bengtson
Reply
This post has been marked as an answer

OK. I'm not sure why that is missing. Try this...

Please check if your license includes the LanguageManagement feature.
Settings > System > License information

Are you using the new permission model?
Settings > Control Panel > Users > Permissions

Does the database have a row for 'LanguageManagement' in the Module table?
Try to execute the following sql statement in Settings > Database > SQL Firehose:
SELECT ModuleControlPanel, ModuleAccess  FROM [Module] WHERE ModuleSystemName = 'LanguageManagement'

Votes for this answer: 1
 
Ivan Marijanović
Ivan Marijanović
Reply

I have licence and it looks like we are not using new model. Also I dont get anything from SWL.

Ivan

Language_Management.png Perrmisions.png SQL_result.png
 
Ivan Marijanović
Ivan Marijanović
Reply

Hi Morten

Thank you for assitance. 

I turned on new perrmsions model and had to go to Settings - System - Module Configuration and install missing modules I got access to Language Management!

Thank you once more!

 

Ivan

 

You must be logged in to post in the forum