Developer forum

Forum » CMS - Standard features » Issue with setting permissions for back-end users

Issue with setting permissions for back-end users

Peter Leleulya
Peter Leleulya
Reply

Hi guys,

I have an issue with setting permissions for back-end users.

I have a cms with 2 websites which have their own shop.
I have a content manager user directory for each shop with their own users, which are set to back-end users.
I have set permissions in the backend on the shops within the product catalog and orders, set to NONE or EDIT, depending on the usergroup-shop match.

Also within settings > Ecommerce > Product catalog > Shops the permissions are set to NONE or EDIT, depending on the usergroup-shop match.

Now when I login to the cms using an account from a content manager, I can select the Ecommerce button in the left navigation.
Within the Product catalog folder it shows only the matching shop, which is correct.
Within the Orders folder it shows both shops, but the non-matching one is grayed out, not sure why it is not hidden like the catalog but still doable.

The issue lies within the dropdown 'All shops' which is shown at the top.
There I can see and select the non-matching shop and then it shows this shop and its contents ...

What am I doing wrong here?
I would like to show only the matching shop in the catalog tree, order tree and shops dropdown.
The dropdown should preferable show just the 1 shop the user has access to, just like the content does ...

Hope you can help me fix this ...

Permissions_Issue.png

Replies

 
Vladimir Shushunov
Reply

Hi,

I see the problem, TFS#67923 is created to fix the issue.

Best regards,
Vladimir

 

You must be logged in to post in the forum