Developer forum

Forum » CMS - Standard features » Email Marketing node not opening (DW 9.10.16)

Email Marketing node not opening (DW 9.10.16)

Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Hi

We aren't able to open the Email Marketing node in our solution. Checked the Event Viewer and it is throwing a IndexOutOfRangeException error.

I've attached screenshots with the log and the EmailMarketing node.

I've changed the values on the Rerun updates option for updates.xml.aspx but didn't fix the issue.

Could it be a platform bug on this version? Should we loop elsewhere?

Capture.PNG

Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

That field is part of update package 2159. So be sure to run that on the database again.

BR Nicolai

 
Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Hi Nicolai

I've rerun updates but it's still throwing the same error.

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Then look into the update log and search for the name of the field. You might not have DDL rights on the database user or something like that.

 
Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Can't find that field on the log or in any other related EmailMarketing tables in our solution nor in past DW versions.

We are only finding this problem in this particular version (DW 9.10.16), could it be that a script is adding that new column but still does not exist in this one?

 
Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Any news about this?

It will impact sending welcome emails when going live.

Also, we are now seeing the error in the attached screendump 

EmailMarketing.PNG
 
Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Any updates?

 
Fabio Monte Dynamicweb Employee
Fabio Monte
Reply

Got it fixed from Oleg's aswer here: https://doc.dynamicweb.com/forum?ThreadID=78528

 

You must be logged in to post in the forum