Developer forum

Forum » CMS - Standard features » Colors in image after resize

Colors in image after resize

Morten Lund
Morten Lund
Reply

Hi

I have a bunch of images uploaded to a folder, where the image resize setting is activated.

The images are in the sRGB colorspace and with plenty of white in them. 

When they are resized the white #ffffff are converted to a light gray #fafafa. When I upload the image to an folder with no resize setting set, the colors are fine. 

Anyone who have experienced the same and can explain why this is happening?


Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

I have not seen that. My guess is that it is the color profile (ICC) - either of the server or embedded in the image?

Tjek if an ICC is embedded - if not, provide us with a sample image so we can have a look at it.

BR Nicolai

 
Morten Lund
Morten Lund
Reply

I think you are right :) – as far as I can see, there's no color profile embedded in the image. I have attached a sample image

test-image_untagged.jpg
 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply
This post has been marked as an answer

Hi Morten

We have reproduced the issue in later Dynamicweb versions. We have also found the setting on the image component that causes this and it is related to handling transparency and background colors of transparent source images.

We need a little time to sort out the issue though and to ensure we do not break transparency. It is registered as bug TFS#83876.

On a side note:

Today we release Dynamicweb 9.9 - in this version the image generation has been isolated in a provider - with a support for a new imaging provider using "Magic scaler" instead of imageglue. This can be enabled by exchanging the provider dll in the /bin folder.

Magic scaler has some advantages over the current implementation - more clear scaling, smaller images for espescially jpegs - and it is .NET core compatible. On the other hand it does not support the same amount of source formats (like psd and the likes). But it is great for 99% of the cases.

BR Nicolai

Votes for this answer: 1
 
Kristian Kirkholt Dynamicweb Employee
Kristian Kirkholt
Reply

Hi Morten

Bugfix TFS#83876 has been released in Dynamicweb version 9.9.1

Package Dynamicweb.Imaging.Providers.ImageGlueProviders

Version 1.0.5

You are able to find this in the download section

Kind Regards
Dynamicweb Support
Kristian Kirkholt

 

You must be logged in to post in the forum