Developer forum

Forum » Dynamicweb 9.0 Upgrade issues » Product catalog list products based on Group

Product catalog list products based on Group

Adrian Ursu
Adrian Ursu
Reply

Hi guys,

Upgrade to 9.4.11. I am using a few product catalog modules in a few landing pages for specific campaigns.

Because it is easier for the admin to select the product group, I am using "Show Product Groups" instead of "Show Index".

In the previous version all went well but after the upgrade the products are not shown anymore. I get a "No products found" message.

I have checked the index and it is fine. The products from this group are displayed in the catalog without any issues.

I have even seen a situation where this setting will only display some of the products in that group (weird).

I have capture a walkthrough in the video below:

https://www.screencast.com/t/8HugDr6Bh1FF

Thank you,

Adrian

Replies

 
Adrian Ursu
Adrian Ursu
Reply

I have dug up more into this issue and apparently it is something related to products.

I have one other group being displayed almost correctly. Meaning that it only displays some of the products from the group.

I have moved one of the products from one group to another and it is displayed correctly.

Which means the Product Catalog module picks up the group information correctly but there is something about the way it decides the products that need to be shown.

In the old version, this type of display was related to the old Ecommerce Searching functionality.

What engine is behind this listing? Some sort of Index? Anything I might need to run manually?

Assortments are not the issue since the products show up just fine in their regular category.

Thank you,

Adrian

 
Adrian Ursu
Adrian Ursu
Reply

Actually, it seems to be an assortment issue.

The products that show up, are not in the general assortment that applies to everybody.

Pretty weird.

I would definitely use a solution for this.

Thank you,

Adrian

 

 
Morten Snedker
Morten Snedker
Reply

Hi Adrian,

I'm not quite sure what "general assortment" means. If a product is in any assortment, it will not be displayed unless you're member of the assortment(s) containing the product. Could this be the case - that not-displayed product is in one or more assortments?

If it keeps troubling you, please write to support@dynamicweb.dk with link to URL of the solution. If so, please also reference this forum thread.

Best regards
Morten

 
Adrian Ursu
Adrian Ursu
Reply

Hi Morten,

Nice to hear from you again :)

General assortment means the assortment that is set to serve anonymous users as well. It applies to everybody.

And no, that's not the case. The products are shown correctly in their corresponding groups.

Think about this scenario. You have products in regular ecommerce categories. And you create a group called "New Products" and aassign some of your regular products in this group.

Then you add a Product Catalog module to a paragraph and select this "New Products" group.  You would expect this setup to display the products from the News Products group, exactly as I would.

Everything is fine if you are not using assortments on the solution.

If you use assortments and all your products are in that assortment (just to simplify the setup), the Product Catalog module will not display anything.

Try it on your local solution and see if you can replicate it.

My past experience with adding anything to support does not encourage me to do it again.

In case you want to see the solution, this is the URL: http://australdev.dotfusion.ro

In the meantime, though, I have switch that display to use the index. But that's a short term solution as I cannot teach the admin how to look up the GroupID everytime they need to add a product catalog with a specific group.

Thank you,
Adrian

 
Adrian Ursu
Adrian Ursu
Reply

Hi Morten,

Here is a direct link to ta page where I set up again the Product Group display:

http://australdev9.dotfusion.ro/promotii/best-deal

Thank you,
Adrian

 
Adrian Ursu
Adrian Ursu
Reply

Hi Morten,

Have you had a chance to reproduce what I described?

Thank you,
Adrian

 
Morten Snedker
Morten Snedker
Reply

Hi Adrian,

Sorry for the delay: I cannot reproduce the error you describe. I've sent you a mail with login to a test solution where I'd like for you to reproduce.

/Snedker

 

You must be logged in to post in the forum