Developer forum

Forum » Hosting » Error retrieving products from index when hosted in Azure

Error retrieving products from index when hosted in Azure

Espen Strømsnes
Espen Strømsnes
Reply

We have a number of sites hosted in Azure. See attached screenshot of the error that has occurred on two instances (DW version 9.4.10 and  DW version 9.4.17).

The problems have been solved by restarting the Azure App Service instances.

Why is this happening, and what can be done to avoid these errors?

Best regards,

Espen

 


Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Hi Espen

That is a good question - i've not seen that before. I've done some digging around, and can see that many other systems using Lucene encounters the same issue (Umbraco, Kentico, DNN etc.).

It seems to arise from lucenes .lock files that gets locked. Could happen if 2 threads are doing the same thing

  1. Are you using a setup with more than one instance?
  2. Ensure you run in 64 bit
  3. Can you check on the log files if the problem occurs same time as other things are happening - i.e. a build of the index?
  4. Do you have more than one index builds of the same index - so you have a failover while the other is being build?

Also, I think it can be solved by deleting the index folders from the file manager and rebuild.

Thanks for clarifying.

BR Nicolai

 

You must be logged in to post in the forum