Developer forum

Forum » Hosting » Assortments on a azure hosted DW solution

Assortments on a azure hosted DW solution

Harald Brouwers
Harald Brouwers
Reply

Hi, I'm running into a problem with assortments I can't solve.

Thes situation is that I have a DW soluton with the new index and assortments. I configured a scheduled taks / scheduler as described here.

The repository is build correctly, as scheduled. And when I look at Integration > Scheduled Tasks. The "Last run" time is also correct. But the actual assortment is not build!

The only way I get my assortments build, is to manually trigger the task with the "Run now" cogwheel.

For our customer this is kindof a problem. Do you have any idea what is causing this? Could it be that the scheduled task has not the right permissions to actually update the assortment?

Greetings


Replies

 
Harald Brouwers
Harald Brouwers
Reply

*bump*

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Hi Harald

Did you setup the scheduler?

http://doc.dynamicweb.com/get-started/introduction/installation/deploying-to-microsoft-azure#4808

BR Nicolai

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Sorry - you have!

I cannot see how permissions should be an issue. What does the log files say?

 
Harald Brouwers
Harald Brouwers
Reply

Hi Nicolai,

Thank you for your response. The log files are strange also. As you can see the run time of the task very recent (a couple of minutes ago), but the acual build of the assortment is almost a week ago. (last manual run as far as I can remember).

 
Harald Brouwers
Harald Brouwers
Reply

*bump*

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

I cannot say why that is the case. You will have to start debugging...

 
Harald Brouwers
Harald Brouwers
Reply

Hi Nicolai,

I'm a bit in the dark here. As you can see in a previous screenshot, im running a -Standard- solution, so no custom code.

The scheduler is setup according to the manual, so that should be correct.

What I see is that running the task url, does trigger the rebuild of the assortments:

https://my.domain/Admin/Public/WebServices/IntegrationV2/ScheduledTaskRunner.aspx?taskId=2&token=12345

So why is the scheduled task not triggering this task on Azure? What's to debug here?

 
Mannon Wekking
Reply

Hi Nicolai, 

This problem still isn't fixed. And we found out that the other scheduled tasks also are not running. For example the scheduled e-mails. 

Can you please take a look at it?

Kind regards, 

Manon Wekking

 

You must be logged in to post in the forum