Developer forum

Forum » CMS - Standard features » Antispam functionality

Antispam functionality

Danni Larsen
Danni Larsen
Reply

Hello

I'm trying to implement hubspot tracking for a DW site, using DW Forms for editors.

Hubspot works in a way, where it looks for form inputs, and tracks the user by eg. email address.

In Forms for editors it has this hidden field with the value of "mrssmith@dynamicweb.com" for antispam. But for Hubspot tracking, it saves every session on the site under the user "mrssmith@dynamicweb.com", because it's the first email that it finds.
DW support told me to turn off "Antispam" functionality in DW settings, but this doesn't remove the fake email.

 

Is there a way to stop rendering the "mrssmith@dynamicweb.com" fake email, so that i can start tracking with Hubspot?

image005.jpg image006.jpg

Replies

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

Hi Danni

You can currently not get rid of that field without creating your own template. We can look into the option of not rendering when antispam is disabled.

Can you supply a link to the feature in Hubspot you are using? Maybe I can find a way to make it work.

Sorry about the inconvenience

BR Nicolai

 
Danni Larsen
Danni Larsen
Reply

Hi Nicolai

I'm not sure that a custom form would be fixing it, as the fake email input, comes from the field "Form.SystemFields".

I guess that i can't just skip this field, and still submit successfully?

Installation: https://knowledge.hubspot.com/reports/install-the-hubspot-tracking-code
Tracking: https://knowledge.hubspot.com/account/how-does-hubspot-track-visitors
Tracking code API overview: https://legacydocs.hubspot.com/docs/methods/tracking_code_api/tracking_code_overview?_ga=2.63288175.1738661820.1630911510-1556902101.1613474735

 

// Danni

template_1.jpg template_2.jpg
 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply
This post has been marked as an answer

Hi Danni

Yes - you can skip the systems fields and the submit logic that comes from default template - when you disable the security on forms, those fields are not used (though still rendered in default template).

I checked the Hubspot docs, and this can be configured - but requires quite a bit of customisation, so I think this approach is better.

BR Nicolai

Votes for this answer: 1
 
Danni Larsen
Danni Larsen
Reply

Hi again

If i outcomment the "@formSystemFields" the form submits and lands on the 404-page.

With the systemfields it works...

I guess this is not the solution then ☹️

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply

You also have to change the action and onsubmit attributes on the form tag.

Remove the onsubmit and change the action to action="" so it will submit to it self.

BR NIcolai

 
Danni Larsen
Danni Larsen
Reply

Hi Nicolai
This doesn't help.
It submits, but just reloads the page with text still in the inputs, and no new entries in DW Backoffice...

 
Danni Larsen
Danni Larsen
Reply

Any other ideas?

 
Nicolai Pedersen Dynamicweb Employee
Nicolai Pedersen
Reply
This post has been marked as an answer

You have to add a hidden field "cmd" with the value "save"

<input type=hidden name=cmd value=save>

Votes for this answer: 1
 
Danni Larsen
Danni Larsen
Reply

That was the last missing piece of the puzzle.

Thank you for the help!

 

You must be logged in to post in the forum