Developer forum

Forum » Dynamicweb 9.0 Upgrade issues
Started by
Last reply
Settings button gone after update to 9.8.1
After updating to 9.8.1 the Settings button in the left bottom corner is gone with the wind while logged in as Administrator. License removed and reset to development version of All-In-One - Professional version 9.8.1 via the login functionality. The ...
Peter Leleulya
25/02/2020 15:43:45
Last post: 25/03/2020 11:20:54
Logo images not rendering correctly (DW 9.8.2)
Hello Logo images are not being rendered correctly in the order detail when using the i.e: Pageview.AreaSettings.GetItem("Ecommerce").GetString("File") method (and images using this method) We changed from GetString to GetFile and it is now working.  ...
Fabio Monte
19/03/2020 12:54:15
Last post: 22/03/2020 19:45:51
NuGet packages Dynamicweb.Admin missing
Hi, All Dynamicweb.Admin packages are missing from MyGet? Is this on purpose? All our builds fail now. ...
Brian Bolks
19/03/2020 17:17:29
Last post: 20/03/2020 08:23:38
Can't edit product group
Hi After upgrading a solution from v9.6.9 to v9.8.2 I get this error when trying to edit a product group. What can be the problem? ...
Lars Larsen
18/03/2020 10:23:01
Last post: 18/03/2020 10:43:47
Item paragraphlist not working after update to 9.8(.1)
Hi, After updating our solution to 9.8.0 (and still after update to 9.8.1) trying to view a paragraphlist for an itemtype crashes for us with the following error: [NullReferenceException: Object reference not set to an instance of an object.] Dynamic ...
Hans Kloppenborg
03/03/2020 13:37:30
Last post: 10/03/2020 08:30:32
Persistent 'your login expired' errors
Hi guys, You probably all know the butt ugly 400 bad request 'login token invalid' error with the 'session expiration' prompt when you try to login ... Normaly I redo my login, which is anoying on it's own, but hey ... then it works ... But since thi ...
Peter Leleulya
04/03/2020 08:34:48
Last post: 06/03/2020 08:47:07
Product loop error in 9.8.0
Hi, We use a product catalog for our product overview. On the template we use the following code to loop through the products: var products = GetLoop("Products"); if (products.Count > 0) { foreach (var product in products) { @if (!string.IsNullOrW ...
John Broers
24/02/2020 17:23:01
Last post: 27/02/2020 11:01:13
Paragraph permission inheritans
I have a 9.7.5 solution with the new permissions model. In the cms in the content tree I have set permissions on a folder for specific user groups. The underlying pages inherit these permissions, as they are supposed to. Paragraphs ON these pages do  ...
Peter Leleulya
26/02/2020 10:07:56
Last post: 26/02/2020 15:40:18
DW 9.8 Save (and close) of existing user not working
Hi, After upgrading our solution to 9.8 it seems that we cannot edit our users any more, pressing save or save and close does a request but the user does not get updated and the close does not trigger. I can still add a new user, and at that moment t ...
Hans Kloppenborg
31/01/2020 10:18:56
Last post: 25/02/2020 15:37:34
NUget install struggles
Installing 9.8.0 through nuget can result into a DotNetCompilerPlatform error. DotNetCompilerPlatform.2.0.1 needs to be downgraded to DotNetCompilerPlatform.2.0.0 in the application file. Then creating Files directory on wizard fails on Admin\Images\ ...
Peter Leleulya
21/02/2020 16:16:21
Last post: 25/02/2020 14:56:17
Greetings, We have an item type for paragraphs that have some image fields. The item type was working fine until we enabled "use focal point selector for images". Since we enabled the feature we get the error "INVALID_FILE_TYPE" when we save the page ...
Anton Marinó Stefánsson
04/02/2020 15:44:16
Last post: 25/02/2020 13:03:27
Did you mean?
Is there a code sample available of the 'did you mean: ...' functionality on search as shown in the DW9.8 webinar yesterday? I liked this feature a lot and would like to play around with it to see if it is easy to implement in our projects ... And of ...
Peter Leleulya
05/02/2020 08:42:11
Last post: 06/02/2020 12:35:11
Missing libwebp.dll when installing Dynamicweb via NuGet packages
Both libwebp_x64.dll and libwebp_x86.dll are missing when installing Dynamicweb via NuGet packages. Which NuGet package should I use to get these dlls? Maybe the Dynamicweb.WebP package should have some dependencies? ...
Niels Foldager
16/12/2019 12:46:01
Last post: 05/02/2020 12:52:49
DW9 replacement of DW8 Dynamicweb.Frontend.Page.IsActive(pageid)?
Hi, Does anyone know the DW9 replacement of de DW8 function Dynamicweb.Frontend.Page.IsActive(p.ID)? This nifty function checked also if the current user had permission to see the page, besides if it was active. We are using the new permission model  ...
Hans Kloppenborg
31/01/2020 16:44:16
Last post: 04/02/2020 09:50:17
Loader exceptions after upgrade to 9.8
I've updated from 9.6.5 to 9.8 - set the framework target - reinstalled all packages including new admin - all references seem to be available - nuget package manager has no dw updates or consolidates left - removed an existing trial license - update ...
Peter Leleulya
29/01/2020 12:15:04
Last post: 29/01/2020 15:25:33
Search V 1 Issue
After upgrading to DW 9.7.3 This only happens when some specific search params are used like 'maintenance' or 'core' also first letter capital seems to trigger the same error: An error occurred while attaching module (Dynamicweb.Frontend.Content) Sys ...
Kevin O'Driscoll
20/01/2020 16:10:38
Last post: 20/01/2020 17:02:25
GetImage not removing white background ( DW 9.7.2 )
Hello I was fixing an issue we were having with png logos being rendered with white background in emails, so we tried to correct it by setting the "Background" parameter in the respective helper but to no avail. Looking at the url for the image witho ...
Fabio Monte
15/01/2020 14:19:38
Last post: 16/01/2020 16:31:29
Product detail not working
Hi guys, We upgraded an application from to 9.7.4 and lateron to 9.7.5. It was a bit of an effort, but we seem to have succeeded. We installed the result on an acceptance environment and downloaded the current production database (compatible ...
Peter Leleulya
15/01/2020 13:01:35
Last post: 15/01/2020 16:31:35
Solution report not working in Dw9.7.4
Hi, If I open the admin of Dw9.7.4 and click on System > Solution report, I get the following error: Unable to cast object of type 'System.IO.DirectoryInfo' to type 'System.IO.FileInfo'. FYI this is a upgraded solution from Dw to 9.7.4 Gr ...
Harald Brouwers
13/01/2020 14:37:41
Last post: 13/01/2020 15:23:29
Cannot attach module in Paragraph after upgrading from to 9.7.5
Hi, I am trying to upgrade Application to Application 9.7.5. I fixed all templates according to DW9 API CHEATSHEET. Frontend is working well. But the admin panel having problem. For example; - I cannot enter into module setting attached in pa ...
Zayar Minn
08/01/2020 10:45:51
Last post: 08/01/2020 11:35:47