Developer forum

Forum » CMS - Standard features » EmailHandler log

EmailHandler log

Terri Donahue
Terri Donahue
Reply

I have checked the Do Not use SMTP pickup directory in the SMTP settings of our site. I am still getting this in the log:

[7/28/2020 9:41:25 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol. 
[7/28/2020 9:41:27 AM]: Mail sent successfully using SMTP protocol. Recipients: 't****i@gmail.com' - CC Recipients: - BCC Recipients: 

Is that expected behavior?


Replies

 
Dynamicweb Employee
Vladimir Shushunov
Reply

Hi Terry,

definitelly it is not expected...

could you check please the value stored in setting:  /Globalsettings/System/MailServer/DoNotUsePickup

In Settings -> System -> Global settings

 

Best regards,
Vladimir

 

 
Terri Donahue Dynamicweb Employee
Terri Donahue
Reply

Here is the setting:

 

 
Dynamicweb Employee
Vladimir Shushunov
Reply

situation not become clear! Lets look error details, it should be a log file:

Monitoring -> Logs -> EmailHandler -> 2020_07.log

or

Files -> System -> Log -> EmailHandler -> 2020_07.log

 
Terri Donahue Dynamicweb Employee
Terri Donahue
Reply

Hi Vladimir,

The log snippet above is from that log. For every email sent, it first logs the Pickup Directory failure, then the sent successfully using SMTP protocol part of the log. Here are some additional log lines:

[7/31/2020 9:33:40 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 9:33:40 AM]: Mail sent successfully using SMTP protocol. Recipients: 'D*r@n*c.com' - CC Recipients: - BCC Recipients:

[7/31/2020 9:45:16 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 9:45:16 AM]: Mail sent successfully using SMTP protocol. Recipients: 'e*5@gmail.com' - CC Recipients: - BCC Recipients:

[7/31/2020 9:45:16 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 9:45:17 AM]: Mail sent successfully using SMTP protocol. Recipients: 'r*s@gmail.com' - CC Recipients: - BCC Recipients:

[7/31/2020 9:45:17 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 9:45:17 AM]: Mail sent successfully using SMTP protocol. Recipients: 'y*c@gmail.com' - CC Recipients: - BCC Recipients:

[7/31/2020 9:51:06 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 9:51:07 AM]: Mail sent successfully using SMTP protocol. Recipients: 'a*t@gmail.com' - CC Recipients: - BCC Recipients:

[7/31/2020 10:11:29 AM]: Send using Pickup Directory Service failed. Trying SMTP protocol.
[7/31/2020 10:11:30 AM]: Mail sent successfully using SMTP protocol. Recipients: 'c*3@gmail.com' - CC Recipients: - BCC Recipients:

 
Dynamicweb Employee
Vladimir Shushunov
Reply

Hi Terri,
I suppose your version DW below 9.6...  
We improved a logging in DW9.6 - it now has a detail log for exceptions.

Could you try to install a Dynamicweb.Mailing package at least 3.0.1 (or newer)?

 
Terri Donahue Dynamicweb Employee
Terri Donahue
Reply

The solution is running 3.0.8. 

 
Dynamicweb Employee
Vladimir Shushunov
Reply

Hi Terry,
well, this sounds very strange for me - because such text in error log was only in Dynamicweb.Mailing versions below 3.0.1. Also I indeed was able to reproduce such weird log in v2.2.3 but not in 3.08

Fortunately, there is a simple check - if you really has Dynamicweb.Mailing 3.0.8 - all detailed error logs should be shown in Monitoring area -> Event viever. Try to filter events here by category "Application/SMTP"

 
Terri Donahue Dynamicweb Employee
Terri Donahue
Reply

Hi Vladimir,

Packages shows something different than solution settings. I'll try the dll update and see if that resolves the logging. Thanks for your help.

 

You must be logged in to post in the forum