Developer forum

Forum » Dynamicweb 9.0 Upgrade issues » Product index builder

Product index builder

Mark Preisler
Reply

Hi

We get the following errors when using product index builder, the error occurs once foreach product being indexed and the customer has 59k products with two instances so that 120k log files are generated when the indexing runs, which causes some problems, after a couple of days / weeks, there are quite a few files

2018-10-24 07:43:10.043: Error process images (AutoID: 54055).. System.NullReferenceException: Object reference not set to an instance of an object.    at Dynamicweb.Ecommerce.Frontend.ImagePattern.FindFilesByImagePattern(String imageCompiled, String imageFolder, Boolean searchSubfolders, Boolean onlyExisting)    at Dynamicweb.Ecommerce.Indexing.ProductIndexBuilder.ProcessImages(IndexDocument document, IDataReader reader, String productId, String productName, String variantId, String languageId)    at Dynamicweb.Ecommerce.Indexing.ProductIndexBuilder.ProcessProducts()

It is in DW 9.5.3

 

Replies

 
Steffen Kruse Hansen
Reply
This post has been marked as an answer

Hi Mike,

We have been able to reproduce the problem, and have created a bug TFS#56665, which should be fixed in the next 9.5 hotfix.

If you are not using the images in the Index, you can disable them in the ProductIndexBuilder settings, which should work as a workaround until the fix comes.

You can see here, which setting to change: https://www.screencast.com/t/E0ezee8u2

Sorry for the inconvenience.

Best regards,

Steffen

 

 

Votes for this answer: 1
 
Mark Preisler
Reply

Hi Steffen Thanks for the quick response, it resolved the problem to set SkipImages to True.

 
Kristian Kirkholt
Kristian Kirkholt
Reply

Hi Mark

The problem regarding #56665 "Repositories index build throws exception when image pattern contains a wildcard" has now been resolved in Dynamicweb version 9.5.5

To upgrade please choose this version from download:

http://doc.dynamicweb.com/releases-and-downloads/releases

Let me know if you need any more help regarding this

Kind Regards
Dynamicweb Support
Kristian Kirkholt

 

You must be logged in to post in the forum