Developer forum

Forum » Dynamicweb 9.0 Upgrade issues » Can't select product in product catalogue when name has quotation marks (9.6.11)

Can't select product in product catalogue when name has quotation marks (9.6.11)

Fabio Monte
Fabio Monte
Reply

Hello all

When adding a specific product in the Product catalogue (choosing the Product option) , if the product has quotation marks in the name, it breaks the Javascript as you can see from the screen dump.

I didn't see this in the bug fixes list so i'm reporting this here.

bugProductName.PNG ProductCatalogue.PNG

Replies

 
Nicolai Pedersen
Nicolai Pedersen
Reply

Hi Fabio

Looks bad indecision - sent to QA for verification and fixing.

Please remember to specify which version of DW you have experienced a problem, thanks!

BR Nicolai

 
Fabio Monte
Fabio Monte
Reply

Hi Nicolai

Thanks. I did wrote the version in the title wink

 
Nicolai Pedersen
Nicolai Pedersen
Reply

Got me there!! wink

 
Oleg Rodionov
Oleg Rodionov
Reply

Hi Fabio,

I was not able to catch the bug on last DW96 (9.6.15) as well as on last DW97 (9.7.3), used browser - last Google Chrome. Please, have a look at the proof and comment if my scenario does not follow yours. Thanks.

BR, Oleg QA

 
Fabio Monte
Fabio Monte
Reply

Hi Oleg

Thanks for the example.

This only happens if a product has double quotation marks, the product you used as an example has single quotation marks and that wont break the javascript.

Try again with one product with double quotation marks (sorry, i should have been more specific here)

 
Oleg Rodionov
Oleg Rodionov
Reply

Hi,

Tested with product has double quotation as you has described on DW9.6.15- no issue caught anyway. Try to clear cache of your browser firstly, please.

BR, Oleg QA

 

 
Fabio Monte
Fabio Monte
Reply

Hi Oleg

I don't think clearing the cache helps. If, in the last example you showed that product had double quotation marks in the middle of its name, then that's when it breaks i.e: "1'17" Daka Replacement", Javascript will think the string ends in the 17.

 
Fabio Monte
Fabio Monte
Reply

Any feedback regarding this?

 
Oleg Rodionov
Oleg Rodionov
Reply

Hi,

I was not able to reproduce the issue with product has "1'17" Daka Replacement" in name as you have written - proof. Tested DW version  - 9.6.15 with last Chrome.

BR, Oleg QA

 
Fabio Monte
Fabio Monte
Reply

Hi Oleg

Maybe try without double quotation marks in the start and end of the product name like this: 1'17" Daka Replacement

 

 
Oleg Rodionov
Oleg Rodionov
Reply

Hi,

I cannot catch the issue anyway.

BR, Oleg QA

 
Fabio Monte
Fabio Monte
Reply

Hi Oleg

Can you check this screencast and see if it helps?

 
Oleg Rodionov
Oleg Rodionov
Reply
This post has been marked as an answer

Hi Fabio,

I was able to reproduce the issue in line with your scenario, the same results are on selecting in list output via 'View more' or on searching inside the list. New TFS 71909 has been submitted against the bug, will be fixed in upcoming release. Thanks for observing.

BR, Oleg QA

Votes for this answer: 1
 
Fabio Monte
Fabio Monte
Reply

Hi Oleg

That's good to know you found it and that it will be fixed.

Best regards

Fabio

 

You must be logged in to post in the forum