Developer forum

Forum » Development » Remove missing rows after import

Remove missing rows after import

Sander
Reply

I have a Data Integration which imports products (and groups) from views to the DW tables (from a Dynamicweb Provider With Views to a Dynamicweb Provider).

The views are the main source, so I basically want to discard anything in the desination that's not in the source; looking at the available options, I figured I could use the option Remove missing rows after import to do so. But nothing that I've tried actually deleted anything in the destination.
I tried setting the option in the desintation setting, and also tried to set it on the specific table settings. 
Also I tried to limit the primary key fields to just the product id (which is unique in our case).

Replies

 
Morten Snedker
Morten Snedker
Reply

Hi Sander,

Sorry for the late reply. Have you resolved your issue in the meantime? If not: which version of Dynamicweb are you running? And what are the primary key settings?

Best regards
Morten Snedker

 
Morten Snedker
Morten Snedker
Reply

Hi Sander,

Sorry for the late reply. Have you resolved your issue in the meantime? If not: which version of Dynamicweb are you running? And what are the primary key settings?

Best regards
Morten Snedker

 
Sander
Reply
This post has been marked as an answer

So I fiddled around with the settings and seemed to have resolved the issue now.

I also had the option Deactivate missing products on. Turning that option off did delete the rows correctly.
I'm not sure whether this is the intended behavior, if so, it may be useful to include it in the documentation.

Votes for this answer: 1

 

You must be logged in to post in the forum