Developer forum

Forum » Development » Forgot password with new permission model

Forgot password with new permission model

Anders Ebdrup
Anders Ebdrup
Reply

Hi Dynamicweb,

 

After switching to the new permission model the regular "Forgot password" (just placing a form on any page) does not work any more as this check: PageIsAccessibleForUser(Converter.ToInt32(reader("AccessUserID"))) in ForgotPassword returns false.

It this intended so we should use the extranet module instead?

 

Best regards, Anders

Replies

 
Martin Vang
Reply

Hi Anders,

I've created a bug for this: "Bug 50869: Forgot Password checked permissions to current page".

I don't quite understand why setup you have for this to happen, but clearly, the check should not be there - it is, however, quite old. Maybe it was more difficult to setup the page-restrictions to trigger this bug in the past?

BR

Martin

 

 
Anders Ebdrup
Anders Ebdrup
Reply

Hi Martin,

 

Will you be able to help me set this up without having to wait for the bug to be fixed?

 

Best regards, Anders

 
Martin Vang
Reply
This post has been marked as an answer

Hi Anders,

Hmm. We can try to come up with a workarround. Or, you can use the bugfix instead? Dynamicweb 9.4.35 has been released (I know this was unexpectedly fast ;)), which contains the bugfix. Installing that package version should resolve your troubles.

If you still have issues, please let me know.

BR

Martin

Votes for this answer: 1

 

You must be logged in to post in the forum