Developer forum

Forum » CMS - Standard features
Subject
Replies
Started by
Last reply
Feature request in paragraph container
I would really like to have the option of setting a class or an ID on a paragraph container, so that I can target my CSS more accurate. I'm testing on rapido 3.2 ...
Siv Hansen
10/10/2019 14:31:46
Last post: 10/10/2019 17:57:44
Using CartViewModel with 'Shopping cart': Unable to render view model template because no view model has been set.
Hi, Using 9.7.2, we are trying to render a 'Shopping cart' step inheriting from Dynamicweb.Frontend.CartViewModel. However, leading the template with @inherits Dynamicweb.Rendering.ViewModelTemplate<Dynamicweb.Frontend.CartViewModel> will resul ...
Roald Haahr Jensen
09/10/2019 12:27:32
Last post: 11/10/2019 11:18:26
Problem with anti-spam feature breaking our websites
Hi, Quick question for everyone. Spammers found our websites and spammed us using the forms. I turned on the anti-spam feature in DW and this did work. However, when it was turned on it immediately broke all our websites. The home page would load, bu ...
Craig Nellist
03/10/2019 09:44:31
Last post: 04/10/2019 09:09:59
ProductListViewModel not returned expected values
Hi, I am currently setting a product list up on a new project running version 9.7.1, where I am inheriting from a ViewModelTemplate<ProductListViewModel>. However, when calling some of the properties and methods accessible on the model, some un ...
Roald Haahr Jensen
02/10/2019 16:51:50
Last post: 04/10/2019 16:35:36
Favorites Products in newsletter
Yo! I was wondering if this was possible using the Email Marketing module. I've created a User Smart Search that gets all users that have added a product to a Favorites List. So in Email Marketing: Can I create a newsletter that generates the favorit ...
Lars Pham
01/10/2019 16:29:55
Last post: 02/10/2019 09:47:46
An item with the same key has already been added at ProductService.GetByAutoIDs
On version 9.6.7 we periodic get this error on a productlist. System.ArgumentException: An item with the same key has already been added. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.Dictionar ...
Thomas Larsen
30/09/2019 14:34:27
Last post: 10/10/2019 17:18:37
BrandColors - Where are they stored
Hi guys, I am trying to figure out where are the BrandColors stored. I see the ItemType is referencing them by BrandColor1, BrandColor2 etc but I cannot find where are stored the HEX values for each. Can anybody help me? And please, don't ask me why  ...
Adrian Ursu
27/09/2019 13:59:16
Last post: 27/09/2019 14:09:05
Add smart search user groups to map
I'm trying to create a map of partners, but I don't understand how to add smart search queries to the map. This is what it looks like on the test server https://www.screencast.com/t/PidL4wgG7M and I'm trying to do the same on live server. There is no ...
Siv Hansen
25/09/2019 12:44:38
Last post: 25/09/2019 14:26:34
Issues with Indexing content
Hi, Using Dynamicweb 9.6.12, I am having some trouble indexing content (using the standard Rapido Index settings) and I need help figuring out what to do next. First I just ran the Index and got 1 error related with Items (Object reference not set to ...
Nuno Aguiar
24/09/2019 19:33:34
Last post: 26/09/2019 17:10:55
"No layout selected for website" when sending email
Hi there. I am having some trouble with sending marketing emails after updating to 9.6.7 from 9.4.11. We have 3 sites under our solution and we can send an email from one of them but not the other two. When previewing the email under the content tree ...
Asdis Gudmundsdottir
24/09/2019 19:04:53
No replies yet
Problem deleting files in folders containing spaces in name
Hi guys, I have recently stumbled across a weird situation while trying to delete a file. The file was below a folder containing a space in its name. And when trying to delete, I got a yellow error: Cannot create"D:/...../Files/Images/xxx yyy/" becau ...
Adrian Ursu
16/09/2019 16:10:07
Last post: 17/09/2019 11:10:42
Can not find "404 for detected robots"
Hopefully somebody can help me I am trying to fix a problem regarding facebook debug returning 404, no mather what I do I suspect it is because 404 for dected robots is switched on. I know it is somewhere, but I just can not find it. Hopefully somebo ...
Hans Ravnsfjall
12/09/2019 15:27:26
Last post: 12/09/2019 17:31:01
WCAG validation error on Cookie warning
We are using the cookie warning shipped with DW, and it contains 2 validation errors according to webaim WCAG checker. In the cookie warning there are two input type button with hrefs inside, which are empty. I've never seen a href inside a button be ...
Siv Hansen
11/09/2019 09:09:38
Last post: 11/09/2019 11:53:47
No canonical tag on products
Hi. We have checked the "Canonical link in meta" under Settings -> Web and HTTP -> Customized URLs -> Ecommerce, but it does not seem to work on any of our products. https://www.realmaeglerne.dk/bolig/371v1331-engagervej-1 The "normal" self  ...
Mikkel Belchuke
10/09/2019 13:24:43
Last post: 26/09/2019 13:18:03
Orphaned statsv2 data
I was working on a cleanup script for stats and noticed that there appears to be a lot of orphaned stats entries. I tested on a current active DW9 and DW8 site. Both are getting daily orphaned entries. Here a couple examples that have results in the  ...
Scott Forsyth
09/09/2019 05:57:42
Last post: 09/09/2019 15:15:35
Page permissions and website permissions
Hello Is there any difference between setting permissions in the website settings vs page permissions? Reading the documentation for permissions it doesn't mention if there could possibly be any differences. I've tested both options and they set perm ...
Fabio Monte
05/09/2019 18:59:39
Last post: 30/09/2019 09:31:35
A/B splittesting error
Our customer Frellsen uses DW version 8.8.0.3, and wants to make A/B splittesting on a paragraph. The paragraph have an Item Type with an Item Relation field attached. We try to create a A/B splittest variant, but we get the error you can see on the  ...
Cecilia Sørensen Vejle
02/09/2019 13:52:38
Last post: 02/09/2019 16:04:14
GetImage and Image preview with SVG file
Hi, We have a customer that's providing a lot of SVG files, but we seen to have 2 limitations: Selecting SVG files as the Product's image (for example) When we try to select an image file, all svg files are excluded Having GetImage process SVG files  ...
Nuno Aguiar
02/09/2019 11:22:07
Last post: 05/09/2019 20:14:26
Assign user to group on Form submit
Hi guys, I am using Forms for editors on DW 9.6.3 and I need to assign a user to a group upon form submit. The user is authenticated, fills out the form (which has Name and Email mapped correctly to user properties) and my expectation would be to ass ...
Adrian Ursu
30/08/2019 13:29:01
Last post: 18/09/2019 18:11:41
Redirect after AD authentication
Hi I have set up an extranet page for login. In the app settings I have choosen the template "LoginWithExternalAccount.html" in the field "Login template" and I have set a page in the field "On login, redirect to". The login provider used is the "Act ...
Lars Larsen
29/08/2019 14:56:32
Last post: 29/08/2019 16:04:03