Developer forum

Currently discussing: Plans to implement a Consent module for GDPR compliance.

Join the discussion!

Forum » CMS - Standard features » Forms for Datalists

Forms for Datalists

Adrian Ursu
Adrian Ursu
Reply

Hi guys,

I am trying to use the Forms for Datalists for the first time.

I have read the documentation and found some default templates in an older solution.

I have setup a custom table and created a form on it.

Everything seems to be rendered nicely in the fornt-end but whenever I try to submit the form, my IP gets banned and the form data never makes it to the table.

What am I missing?

Thank you,

Adrian

Replies

 
Nicolai Pedersen
Nicolai Pedersen
Reply
This post has been marked as an answer

Go to settings and add your email to get a copy of the injection report - and see what it contains! It might contain a field or table name that SQL injection does not like at all. You can take them out of the check in the settings as well.

BR Nicolai

Votes for this answer: 1
 
Adrian Ursu
Adrian Ursu
Reply

Hi Nicolai,

Thank you for the idea. I have to get used to this injection emails.

Thank you,
Adrian

 
Nicolai Pedersen
Nicolai Pedersen
Reply

If you tell me the hostname, I might be able to find a report in my lists.

Come to think of it - it could also be form spam check... You can also disable that to see what happens.

 
Adrian Ursu
Adrian Ursu
Reply

Hi Nicolai,

bet.dotfusion.ro is the hostname. 

But I have forwarded you suggestion to my coleague and he will make the test.

We should be fine.

I should have thought of that.

Thank you,

Adrian

 
Adrian Ursu
Adrian Ursu
Reply

Hi Nicolai,

I have cleaned up my data and tried a very basic form (one field) witha standard template.

Although the message after submit says: your data has been saved, I see no rows inserted in the table.

Reading is fine (I have inserted some data manually in the table).

Any idea? I am running 9.3.5.

Thanks,

Adrian

 
Adrian Ursu
Adrian Ursu
Reply

I have just displayed the templatetags after submit and the tag Form.SaveStatus says: Form not saved.
Is this "Save" action dependent on any of the Form events?

Thanks,

Adrian

 
Adrian Ursu
Adrian Ursu
Reply

I have found a log of the forms module.

Maybe it sheds some light because I have no other ideas.

I have upgraded to 9.4.11, I have activated send form by email (and it was sent), I have tried templates from another project (proven that it works).

I need some help.

Thank you,

Adrian

 

 
Nicolai Pedersen
Nicolai Pedersen
Reply

I've asked the service desk to contact you and take a look...

 
Adrian Ursu
Adrian Ursu
Reply

Hi Nicolai,

Thank you,

Adrian

 

You must be logged in to post in the forum